[Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Discussions sur les anciens ordis souvent ludiques et familiaux (Amstrad, Atari, Amiga, ...).

Modérateurs : Membres WDA, Modérateurs complets

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

[Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 28 févr. 2010, 21:37

Bonjour,

J'ai entamé la restauration de mon Vegas 6809 (viewtopic.php?f=28&t=1626). L'alimentation semblait faiblarde, mais au 2ème essai, bip, le moniteur s'allume et l'invite apparait. Par contre le lecteur de disquette ne marchais pas. Après quelques essais infructueux, je vais dormir (je travaille tard le soir)
Le lendemain matin: plus rien, plus de bip, plus de moniteur ... Horreur
J'ai inspecté au scope les signaux de base: horloge, R/W, Chip Select, ... Le processeur a une activité, mais impossible de savoir ce qui se passe.
Je n'ai pas d'analyseur logique pour regarder où ça plante, j'ai toute la doc et même un listing de l'eprom du moniteur.

Quelqu'un a-t-il une expérience en la matière ? Une aide serait la bienvenue pour déterminer le circuit qui a lâché. Tous les composants se trouvent encore, il doit donc être possible de la réparer !

A votre bon coeur et merci d'avance
Cordialement
Frédéric

Avatar du membre
irios
Posteur motivé
Posteur motivé
Messages : 35
Enregistré le : 05 mars 2007, 11:14
Collectionneur (-euse) ? : Oui
Localisation : Rochefort du Gard (30)

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar irios » 05 mars 2010, 20:35

Salut !!
Dans un premier temps, il faudrait vérifier les tensions d'alimentations puis ensuite à l'aide d'un programmateur d'eprom, vérifier le contenu de l'eprom.
La suite au prochain numéro ... :mrgreen:

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 888
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar Krapoutchik » 05 mars 2010, 22:36

Bonsoir,

Enlever / remettre tous les circuits sur support (faux-contact ?).

Check de l'alim et de toutes les tensions, sur certaines vielles cartes micro comportant des Eproms type 2704, 2708 ou les premières séries de 2716 il y avait une chronologie à respecter dans l'établissement de l'ordre des tensions, +5 en premier puis +12 puis -5 puis -12v par exemple.

Tu as un scope donc vérifie les résiduelles d'ondulations sur toutes les tensions, changer les condos de filtrages, en règle général les condos électrolytiques sont les éléments les plus fragiles et vieillissent mal (condos "secs").

Regarde particulièrement le circuit de reset du processeur, il était le plus souvent composé d'un simple circuit RC qui générait un reset 1/2 ou 1 seconde après la mise sous tension, si le condo du circuit RC est sec tu peux avoir un reset beaucoup plus court qui arrive trop vite avant que les tensions soient stabilisées ce qui entraine une mauvaise init de toute la carte cpu.

Si tout te semble normal commence par changer tous les électrolytiques autour de l'alim puis vers la cpu et refaire les soudures.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 09 mars 2010, 11:46

Bonjour,

Merci à Irios et Krapoutchic pour leurs conseils.
J'avais pensé au pb d'alim et j'avais utilisé une alim de PC pour tester la CM. Donc pour l'alim, ce sera pour plus tard, mais les condensateurs seront surement à changer ...
Pour le circuit de reset, je n'y avais pas pensé, je vais regarder cela ce week-end. Dès que j'aurais un programmateur d'EPROM, je vérifierais aussi qu'il n'y a pas d'altération du code.
En fait, je ne sais pas la durée de vie d'une 2716?

Bien, je vous tiens informé de la suite de mes investigations.
D'autres part, j'ai des problèmes avec les floppy. Il semble qu'une disquette se soit détériorée et ai encrassé les lecteurs. Résultat, 2 disquettes HS (rayées irrémédiablement) et je ne parviens plus à écrire avec les lecteurs de floppy après les avoir nettoyés les têtes à l'alcool (test sur un PC sous DOS).
Avez-vous une idée pour les floppy ?

Merci pour tout et à bientôt
Frédéric
Cordialement
Frédéric

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 15 mars 2010, 15:01

Bonjour,

Suite de mes aventures. Je me suis acheté un analyseur logique et j'ai testé le microprocesseur ce we. La première chose que fait le microprocesseur est de lire son adresse de démarrage à froid en $FFFF et $FFFE. Le reset se fait bien. Là il lit $2838 au lieu de $E8F8. Les 2 lignes D6 et D7 sont toujours à 0.
J'ai testé les connections et nettoyé les pinoches du microprocesseur et de l'EPROM. Le test suivant montre que le processeur va plus loin mais toujours pas de boot. Je n'ai pas eu le temps de tester plus.
J'ai peur que le long séjour en cave humide n'ai oxydé les pinoches des composants et peut-être des supports (ce ne sont pas des Tulip) Je suis bon pour tout démonter et nettoyer!

Avez-vous des astuces pour nettoyer les pattes des composants ? WD40 ? Autre produits ?
Je reste à l'écoute !

La suite tardera un peu car je ne retournerais pas en Bretagne où se trouve mon équipement avant 2 ou 3 semaines.
Cordialement
Frédéric

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 888
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar Krapoutchik » 15 mars 2010, 17:27

Bonjour,

Eh bé on ne peut pas dire que tu ne mets pas les moyens pour réparer ta VEGAS !

Je te déconseille fortement le WD 40 qui est plus fait pour de la mécanique et à une action lubrifiante et nettoyante comme le Dégrip-oil et te laissera d'importants résidus huileux sur ta carte , utilise plutôt du KF Contact F2 ou un équivalent conçu pour de l'électronique.

Effectivement les support "Lyre" des années 80 sont une vraie catastrophe et s'oxydent très vite en présence d'humidité. Après avoir passé du KF il te faudra enlever et remettre plusieurs fois chaque circuit pour être sûr de récupérer un contact correct. J'ai déja vu des support de ce type dont la base était complètement bouffée entre le circuit et l'epoxy donc il te faut systématiqement vérifier la continuité électrique de la broche avec le coté soudure.

Ton analyse sur D7 et D6 bloqués au niveau bas est bonne mais j'ajouterais D14 et D15 (tu lis 2 au lieu de E ).
1110100011111000 = E8F8
0010100000111000 = 2838

En règle générale, en TTL, un niveau bas doit se balader aux alentours de 0,3 v, un haut vers 4,7, les 0,3 v de différence correspondent à la tension de déchet Vce du transistor de sortie du CI.

Un petit truc pour tester rapidement ton bus de donnée ou d'adresse , tu soudes 2 résistances de 2,2K en série, tu relies chaque extrémité au 0V et au 5V, sur le point milieu des résistances tu soudes un bout de fil que tu balades sur ton bus et tu vérifie avec ton scope que le niveau de tension sur la broche testée ne varie pas ou très peu (maximum 100mv), si ta tension monte ou descend d'un niveau plus important cela veut dire que le circuit de sortie en amont est mort (ou pas loin de l'être), en cas de doute utilise un injecteur de signale pas cher, ton doigt ! si ton scope te montre une ondulation à 50 Hz, c'est pas bon.

A+
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 15 mars 2010, 21:23

Merci à Krapoutchick pour ta réponse.
Ton analyse sur le bus est vrai, mais le 6809 charge son adresse en 2 fois avec des mots de 8 bits. Son bus ne fait que 8 bits, donc D6 D7 se superpose avec D14 et D15 que tu indiques.
Pour le F2, ok, je vais l'utiliser, à la fois sur les supports et les pattes des circuits.
Ton astuce pour tester les résistances me semble intéressante. En effet, 2,2kOhm ne devrait pas changer le niveau ... sauf si la patte est en l'air ou en haute impédance (mais alors ce sera un 2,5 v tout propre !). Je vais me faire un petit outillage de test. Actuellement, au scope, on voit de la friture sur plusieurs pattes de circuits, je suppose que c'est du à une résistance de contact trop importante quelque part.

Pour les moyens, oui, j'ai horreur que le matériel me résiste, et là, c'est un point d'honneur!
L'analyseur me resservira si je fais des circuits avec des pics. Et puis c'est un analyseur USB, bien moins cher qu'un vrai ;)

Merci et à plus
Cordialement
Frédéric

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 06 avr. 2010, 21:40

Bien, pour la suite de mes investigations, j'ai utilisé les grands moyens: oscilloscope et analyseur logique. C'est peut-être un peu exagéré, mais bref, j'ai bien progressé.
P1010957.jpg
La carte mère en test

Après avoir testé chaque ligne de donnée à l'oscilloscope pour voir les mauvais contacts, j'ai passé du F2 et gratté les pattes du 6809.
Après 2 essais, miracle, l'analyseur logique montre que je prend bien l'adresse du reset et je commence la séquence d'initialisation des vecteurs d'interruptions.
Malheureusement, cette séquence se fait avec un sous programme. L'adresse de retour est bien initialisée dans la pile, mais à la fin du sous programme, l'adresse de retour est erronée. La lecture en RAM ne marche pas (à moins que ce ne soit l'écriture, mais j'ai des signaux bizarres à l'oscilloscope sur certaines lignes)
Le problème de base est que le microprocesseur ainsi que les RAM sont montés sur des supports lyres simples qui sont donnent des contacts aléatoires.
Je ne me vois pas désouder les supports pour mettre des Tulip, j'ai peur de détériorer la carte. Avez-vous une expérience de souder un support Tulip sur un support Lyre ? Cela a-t-il un sens ???

En suite les WE sont trop court, je n'ai pas encore résolu le pb, mais ça avance.
La suite après les vacances de Pâques. :clap:
Fichiers joints
P1010959.jpg
Test avec analyseur logique
Cordialement
Frédéric

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 888
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar Krapoutchik » 07 avr. 2010, 09:07

Salut,

Je pense que tu devrais F2isé et grattouiller tous les circuits sur support (coup de F2 puis enlever/remettre les circuits plusieurs fois de suite, au bout de 10 pavés t'auras les doigts en sang !), je vois que les supports sont des simples lyres - condoléance :pray: - ce sont les pires m.. :censored: .. que j'ai jamais vu, dans une de mes premières boites (long, long time ago !) j'ai passé un temps appréciable à dessouder des doubles lyres de banques mémoires pour mettre des tulipes à la place (très facile et très rapide à enlever avec une pompe à dessouder, prise de tête mais faisable même sur du trou métallisé et très lent avec une pompe manuelle ), souder un support sur un autre support ! pas joli, très prise de tête et résultat pas garanti surtout avec de la simple lyre, il vaut mieux passer un peu plus de temps et dessouder proprement (remarque, je serais à ta place je me demande ce que je ferais :mrgreen: ).

A+ et bon courage

Ps : Pas mal ton scope, petit et maniable c'est quoi comme marque ?, je m'en achèterais peut-être un le jour où mon Tektronix de 35 ans me lâchera).
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 04 mai 2010, 22:20

Bonsoir,

Suite de mes recherches sur mon impitoyable Vegas (TM de Krapoutchik qui à des références chez Dallas!)
Il semble que des ram ne répondent pas. Après 15 ou 20 démontages - F2 - remontages, certains bits sont toujours à 1 :wall:
Sur la carte, il y a 8 boitiers de mémoire 64 x 1 bits, certains sont peut-être HS.
Je vais voir si j'en retrouve ...

Allez, la suite aux prochaines vacances ... :doh:
Cordialement
Frédéric

F5onr
Messages : 5
Enregistré le : 15 mai 2010, 17:42
Collectionneur (-euse) ? : Oui

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar F5onr » 15 mai 2010, 23:34

Bonjour,

J'ai eu l'occasion de réaliser quelques VEGAS 6809 sous Flex.
Ca n'est pas la plus performante, mais c'est la machine qui m'a sans doute le plus appris...
C'est vrai que c'est une carte qui consomme é-nor-mé-ment !

S'ils sont sur support, je commencerais par ôter les 6850, le 6821 qui ne sert pas au clavier, le contrôleur de disque pour vérifier que ça ne vient pas de là...
Pour voir si une RAM ne pollue pas le bus, il faut les échanger deux par deux, pour vérifier que le problème se déplace avec l'une d'entre elle.
Pour ce qui concerne le Reset, il faut attendre 5 secondes après la mise sous tension, puis passer la broche reset du 6809 par 0 à l'aide d'un bout de fil. Mais normalement un bouton Reset était prévu.

Je confirme que les supports lyres ne sont pas top.
A la limite, tout dessouder (je sais, c'est long!) et ressouder des tulipes ou directement les composants.
Puis passer les 74LSxx d'origine en 74HCxx pour gagner en conso.

Juste un truc : Les adresses de retour des sauts de type JSR sont empilés en RAM : Si tu as un pb de RAM, ça peut altérer les retours.

73's
F5onr

F5onr
Messages : 5
Enregistré le : 15 mai 2010, 17:42
Collectionneur (-euse) ? : Oui

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar F5onr » 15 mai 2010, 23:39

Re-bonsoir,

Juste un truc: je me souvient que les cartes étaient 'overcloquées' en 6MHz au lieu de 4MHz dans certains cas.

Une carte graphique 256 couleurs (!) avait été développée pour VEGAS, (elle permetait l'incrustation vidéo, le top du top)
J'ai également eu l'occasion de développer des interfaces SS30.
Ton ancètre en est-il équipé ?

73's et bon courage
F5onr

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 18 mai 2010, 19:34

Bonsoir F5onr,

Je suis d'accord avec ton analyse, c'est la RAM qui ne marche pas, mais c'est pas facile de détecter laquelle car j'en ai au moins 4 ou 5 qui ne marchent pas!
Pour le bus SS3 et le graphique, j'ai pas. Je suis intéressé par tout cela, et si c'est faisable, je fabriquerais! As tu des documentations?

Pour l'overcloque, c'est surement possible, mais alors il peut y avoir des pb d'accès disquette je suppose. Je préfère rester à la vitesse d'origine.
Pour les 74ls, oui, je pense le faire quand tout re-fonctionnera.

Merci en tous cas.
Cordialement
Frédéric

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar leduigou » 14 juil. 2010, 22:28

Bonjour à tous les passionnés qui s'inquiètent de l'état de santé de mon Vegas.
Bonne nouvelle, après des mois dans le coma, en réanimation, il a repris connaissance le 12 juillet après une greffe de RAM et un bouteille de spray de F2 :P

En voici la preuve:
P1020149.jpg
Moniteur 80 MICROKIT


J'ai maintenant le moniteur et le clavier qui marchent. Le timer 6840 reste lui inerte, mais je suis sur la bonne voie ...
P1020157.jpg
Le clavier d'origine


Malheureusement, le lecteur de disquette ne marche pas, je pense que les disquettes sont completement HS. Impossible de les lire, dès qu'elles sont dans le lecteur, on voit des anneaux concentriques gravés par les têtes de lecture, et de la poudre noire (avec les précieuses informations) qui s'envole ...
Avis, si l'un de vous à une disquette de boot pour Vegas, merci de m'en faire une copie ou une image ::wink:

J'ai hate de lui redonner sont intelligence maintenant!

A+
Cordialement
Frédéric

Avatar du membre
TRS-80
Posteur motivé
Posteur motivé
Messages : 39
Enregistré le : 08 oct. 2009, 08:22
Collectionneur (-euse) ? : Non

Re: [Restauration] - Carte Mère Vegas 6809 - Besoin d'aide!

Message non lupar TRS-80 » 17 oct. 2010, 09:19

Bonjour Frédéric,
Suite à notre conversation dans les locaux de l'Association, As-tu contacté Christian TAVERNIER http://www.tavernier-c.com/index.html ? Il avait publié dans la revue "Haut-parleur" un micro identique au VEGAS 6809 dans les années 1980.... il s'appelait "LE TAVERNIER". Bien qu'il n'était pas compatible au niveau du Flex !"Toutefois, la version Flex de l'Vegas n'était pas compatible avec les versions Tavernier et Goupil." Information de : http://www.old-computers.com/museum/com ... c=248&st=1. Il connait peut être les différences (il a adapté le Flex09 à son micro) et il connait peut être l'adresse ou te procurer un Flex avec les différences et les modifications à effectuer!!! ctc@tavernier-c.com !!!. La revue Elector a publié aussi un micro, qui si mes souvenirs sont exacts est sur la base du 6809 avec "FLEX 09", sont nom "Junior?????" http://www.elektor.fr/.
Christian TAVERNIER semble publier maintenant dans la revue Elector. Ces personnes accroc depuis 30 ans et + de micro, devraient apprécier tes efforts de conservation de vieux micros !!!!
A+
TRS-80
P.S.
1) Je suis à la recherche d'un clavier à bus parallèle en boitier (idem à ton Vegas), pour remplacer mon clavier sans boitier qui équipe mon Prof-80 (voir ma collection). Si tu connais une source d'approvisionnement, fait moi signe.
2) Tu pourrais peut être demander à Christian TAVERNIER un "TAVERNIER et/ou le C.I. et/ou des reliques du TAVERNIER" pour la collection de WDA!!!

Des adresses: http://www.flexusergroup.com/flexusergroup/fug2.htm Sur ce site tu peux trouver un émulateur, docs pour modifier et adapter Flex09 et donc peut être tout le nécessaire pour créer un disque image!!!Dans les membres de cette association, j'ai trouvé des Français"Christian LE GAL" "Joël SETTON" ils travaillent peut être sur VEGAS?????!!!!!!
France http://www.flexusergroup.com/flexusergroup/fug4.htm http://www.flexusergroup.com/flexusergr ... 09fadg.pdf
http://www.tucows.com/preview/324082
http://libelle-systems.com/personal/flex09/flex09.html


Retourner vers « 8 bits, Ordinateurs personnels et autres Sasfépus »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité