[Remise en route] - DAI et lecteur MEMOCOM

Discussions sur les anciens ordis souvent ludiques et familiaux (Amstrad, Atari, Amiga, ...).

Modérateurs : Membres WDA, Modérateurs complets

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 883
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

[Remise en route] - DAI et lecteur MEMOCOM

Message non lupar Krapoutchik » 28 mars 2016, 22:27

Ca me démangeait de remettre en route mon DAI accompagné de ses 2 lecteurs Memocom aussi appelé Philips MDCR.

Comme d'habitude, démontage, inspection minutieuse à la recherche de composants abimés, pistes abimées, coulure de condensateur etc...et bien sûr une attention particulière pour l'alimentation.

Multimètre connecté sur le +5V , Ignition !

Hum, 4,75 V au lieu de 5V, l'écran d'accueil avec le logo DAI est bien là, aller hop enter pour passer au basic et...
Mouais pas terrible, j'ai bien le prompt, le clavier réagit correctement mais entre chaque ligne j'ai des petits points et les 2 dernières lignes de l'écran ne sont pas visibles ::roll: .
Par contre un petit programme simple genre 10 print "toto" 20 goto 10, fonctionne correctement.

Tiens la tension descend à 4,50 ::( , bon j'éteins.
A tous les coups un des nombreux condensateurs au tantale est en train de faire un c**a nerveux , mon premier DAI a eu exactement le même problème.

Il n'y a pas 36 solutions, je rallume, zut, l'alim siffle comme c'est pas permis, extinction, re-examen de tous les condensateurs tantales et chimiques, pas de température anormale, pas de changement de couleur ni d'odeur de cramé, rien aucun symptômes visibles :think: .

Re-re allumage, la tension remonte à 5,10, Super :banana: , plus de petits points sur l'écran et je vois bien les 2 dernières lignes de l'écran.
C'est rigolo, c'est le 2eme DAI qui se répare tout seul :jump: . Certainement encore un de ces maudits tantales, je ne le saurais jamais, pour bien faire il faudra tous les remplacer par des neufs mais j'ai un peu la flemme, d'autant plus qu'il y en a un bon paquet ::oops: .

La suite est plus classique, mise en chauffe pendant plusieurs heures, cycle d'extinction et allumage, tout se passe bien :8: .
Connexion des lecteurs MEMOCOM, pas si trivial que ça à faire, les connecteurs n'ont pas de détrompeurs, on peut donc les mettre à l'envers par contre un petit triangle sur chacune des parties mâle et femelle indique la patte 1.

Les 2 lecteurs fonctionnent impeccablement et lisent toutes les cassettes, il faut dire que je leur ai bien lavé les têtes de lectures qui avaient de jolis dépôts d'oxyde.
Mon seul souci a été de comprendre comment lire et exécuter un programme sur cassette. Les docs ne sont pas très clairs.
LOOK permet de voir le nom du programme sur cassette, pour l'exécuter il faut faire simplement LOAD:RUN, mais cette commande ne fonctionne que sur un programme en BASIC reconnaissable au 0 devant le nom . Si c'est un 1 c'est un binaire qui ne peut être que chargé (LOAD"nom du programme"), pour l’exécuter il faut passer en mode UT et taper... je ne sais pas encore :think: .
SKIPx où x est un chiffre permet de passer à x programmes après celui sur lequel on est.
REW permet de rembobiner la cassette.
DCRx permet de passer au lecteur x où x = 0 à 3 car on peut chainer 4 lecteurs.

Quelques exemples....
uc&memocom.jpg


La Joconde, le visage s'anime et en même temps il y a quelques bruitages.
joconde.jpg

joconde1.JPG


Quelques exercices de logiques...
logique.jpg

logique3.jpg


Un peu de géographie (en néerlandais :eeeek: ).
carte1.jpg
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Retourner vers « 8 bits, Ordinateurs personnels et autres Sasfépus »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité