[Restauration] - ITT 2020

Discussions sur les anciens ordis souvent ludiques et familiaux (Amstrad, Atari, Amiga, ...).

Modérateurs : Membres WDA, Modérateurs complets

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

[Restauration] - ITT 2020

Message non lupar Attafr » 12 nov. 2017, 17:07

Bon une p’tite pause avec le Junior...
Donc j’attaque l’ITT2020 avec plusieurs questions !
Existe t’il un « chip » compatible à un 74LS153 ?? Répondez pas 74153 ou 74hc153, g pas !!
Je sais qu’il y a une ROM particulière pour le PAL, mais est-ce que des ROM Apple peuvent faire l’affaire dans un premier temps ??
Qu’elle sont les ROM minimun pour démarrer la machine ??? (G dispo toutes les Rom d’un Apple II+/europlus)
Apparemment cette machine a vécu dans une rivière avec des rats et des castors...
4B434C64-90B8-4B1B-A0A8-9BF9AFFD6CE8.jpeg

C01E6261-8A31-4C41-99A1-A83F7F958FD0.jpeg
Modifié en dernier par Casio le 17 nov. 2017, 14:28, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
6502 "Addict" ,mon fils ma bataille...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 884
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - ITT 2020

Message non lupar Krapoutchik » 12 nov. 2017, 20:48

Ouah .... mais où s’arrêtera t-il :eeeek: , prochaine étape tu nous sors un ZX 80 et puis, en dessert, un Apple 1 :mrgreen: .

Je ne connais pas du tout l'ITT et je n'en ai jamais vu en fonctionnement mais il semble que l'on puisse remplacer les roms d'origine par des roms de 2+ (source ici).
Par contre j'ai une interrogation, en effet, j'ai vu 2 photos de cartes mères de 2020 identiques à la tienne, une avec des roms Apple et l'autre avec des eproms. Normalement on ne peut mettre une eprom qu'avec un adaptateur :think: .

En tous cas, la carte mère est très propre, j'imagine que tu as dû passer pas mal de temps à la nettoyer et la désoxyder :clap: .

Le remplacement d'un 153 par autre chose n'est pas simple mais néanmoins faisable, le seul souci est que tu risques de passer plus de temps à faire un petit montage de 2 ou 3 boitiers et à les raccorder à la circuiterie d'origine qu'à commander le circuit dans n'importe quelle bonne crémerie ::lol: .
En remplacement le plus direct tu peux aussi prendre un 74LS253 qui est identique mais comporte des sorties 3 états, il faut dans ce cas mettre une résistance de tirage d'environ 1k au 0v sur les sorties pour éviter qu'elles ne se retrouvent en mode haute impédance.
Modifié en dernier par Casio le 17 nov. 2017, 14:28, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

Re: [Restauration] - ITT 2020

Message non lupar Attafr » 12 nov. 2017, 21:25

ZX80 bientôt :P
Apple I aussi mais en NT1 :mrgreen:
J’ai trouvé un 153 dans mon barda, alors ça va le faire, si j’arrive à le dessouder !
A l’origine il (l’ITT) avait des ROMS, il en restait une dessus, mais apparemment foutue ! En tout ka elle tourne pas sur mon Apple II, je vais essayer de mettre des Rom apple, on verra bien!
La j’ai pu à peu près tout tester sur une carte Apple Il, ram, chip, pas encore l’alimentation, mais en attendant j’utilise celle d’un Apple !
Tout a l’air ok! Je dois encore tester les ne555, mais ça j’en ai une brouette ::wink:
A+
Modifié en dernier par Casio le 17 nov. 2017, 14:29, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
6502 "Addict" ,mon fils ma bataille...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 884
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - ITT 2020

Message non lupar Krapoutchik » 12 nov. 2017, 22:35

Attafr a écrit :ZX80 bientôt :P
Apple I aussi mais en NT1 :mrgreen:

Ention et damnafer, Damned :eek:...

J'ai compris ton secret, tu prends ta DeLorean, un petit coup d'autoroute à la vitesse de 88 miles et hop... une petite tournée de magasins d'électronique/informatique dans les années 77-80, facile !!!
Je m'en veux de ne pas y avoir pensé avant :mrgreen: .
Modifié en dernier par Casio le 17 nov. 2017, 14:29, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

Re: [Restauration] - ITT 2020

Message non lupar Attafr » 16 nov. 2017, 17:29

Bonjour,
Non, je n'ai pas abandonné, mais il ce défend le bougre...
P'tite question, si on "lit" le bus "DATA" ou "ADDRESS", ça peut ce lire "partout" ?, sur le CPU et sur les "Slots" ou c'est seulement où il y aurait le "Chip select" ?
J'ai bricolé un bidule que je peux "insérer" dans un "Slot" et je connecte mon analyseur ou mon ossillo dessus, ça marche en tout qu'à pour la/les fréquences !
Je sais que ceci n'empêche pas de devoir controler après ailleurs, mais si je lis sur le slot, après je peux par exemple contrôler si j'ai la même chose sur le CPU ou une MEM/ROM par exemples !
Modifié en dernier par Casio le 17 nov. 2017, 14:31, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
6502 "Addict" ,mon fils ma bataille...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 884
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - ITT 2020

Message non lupar Krapoutchik » 16 nov. 2017, 21:54

Je n'ai pas le schéma de l'ITT mais il se pourrait qu'il soit très proche de celui de l'Apple.
Si c'est le cas, le bus d'adresses et de données est commun à tous les niveaux (eprom, ram, slot...) sauf au niveau du proco où il est tamponné par des 8T97 pour les adresses et par des 8T28 pour le bus de données.

Quel est le problème ?
Modifié en dernier par Casio le 17 nov. 2017, 14:31, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

Re: [Restauration] - ITT 2020

Message non lupar Attafr » 17 nov. 2017, 00:03

Le problème ou les problèmes ? Pour l'instant je test toute les données que je peux récupérer "pour m'instruire" sur un Apple II+.
J'ai par exemple testé la partie "Timer" Phi0,1, sortie du quartz (14M, ça moitié 7M, Color Ref etc...)

image.jpeg


Avec un bricolage...

image.jpeg


Ce sont des "vraies" ROM de l'Apple II+ sur la photo, j'ai juste collé des étiquettes, car avec mes yeux de taupe, c'est plus facile à lire, pas que l'on croie que ce sont des EPROMS !

C'est qu'en électronique, je suis un "bille" ::roll:
J'ai beaucoup lu ici : http://www.willegal.net/appleii/appleii-repair.htm et petit à petit je comprend ::lol: mieux...
APRÈS je m'attaquerai à l'ITT qui ressemble comme deux gouttes d'eau à l'Apple sauf quelques détails : https://en.m.wikipedia.org/wiki/ITT_2020

Pour ce qui est des "PROM" 8T97 (c'est vrai aussi sur Apple) c'est des 74LS367 !?!

PROBLÈME sur l'ITT, j'ai de la vidéo "pourrave", pas de caractères, mais plutôt une espèce de "truc" graphique ?!, mais pas de beep, ni de curseur ?! Donc, une fois que j'aurais compris quoi et où mesurer après mon apprentissage sur l'Apple II+, je pourrais peut être mieux expliquer le problème, soit résoudre le problème ::lol:
Modifié en dernier par Casio le 17 nov. 2017, 14:31, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
6502 "Addict" ,mon fils ma bataille...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 884
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - ITT 2020

Message non lupar Krapoutchik » 17 nov. 2017, 12:57

Bravo pour le bricolage :boohoo: !
Arf... On a les mêmes amusements :mrgreen: mais tu es nettement plus outillé que moi :clap: , l'analyseur logique sera mon prochain achat, je n'ai plus qu'à écrire ma lettre au père noël :pray: .

Il y a 2 bouquins vraiment bien traitant de l'Apple 2 dans tous les détails et trouvables facilement sur internet en version PDF.
"Understanding the Apple II" par James Fielding Sather
" The Apple II Circuit Description" par Winston Gayler

Le LS367 est compatible broche à broche avec un 8T97 qu'il peut remplacer.
Le seul souci est que le 367 est en moyenne 20 à 30% plus lent que le 8T97 et même 3 fois plus lent à réagir pour valider ou dévalider le mode haute impédance. D'un autre coté l'échelle des écarts de vitesse se situe dans la dizaine de nanosecondes donc ce n'est pas dramatique non plus.
En résumé, ça peut marcher ou pas ::roll: .

Concernant le "n'importe quoi à l'écran", toute la mécanique d'affichage est indépendante du processeur donc sans proco on affiche quand même quelque chose.
Si ça ne beep pas c'est que le proco ou la logique autour ne fonctionne pas.
En pratique la panne se situe quasiment toujours dans le premier banc mémoire de 16K, une ram HS suffit.
Bien sûr le problème peut provenir aussi d'un circuit périphérique qui n'arrive pas à écrire ou lire la ram.
Modifié en dernier par Casio le 17 nov. 2017, 14:31, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

Re: [Restauration] - ITT 2020

Message non lupar Attafr » 17 nov. 2017, 17:10

L’analyseur Logique, c’est une ´framboise avec un board velleman VM205 !
FE376988-9490-4138-A434-58884642B3A6.jpeg
6502 "Addict" ,mon fils ma bataille...

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

Re: [Restauration] - ITT 2020

Message non lupar Attafr » 18 nov. 2017, 00:17

Bon, ça commence mal... Normalement sur la pin 8 du 74S86, je devrais avoir la sortie du quartz à 17Mhz, j'ai (déjà) la moitié 8.5Mhz ce que je devrais trouver sur 7M (voir plus haut, l'image "synchronisation")
Pourtant la même mesure sur mon II+ me donnait bien 14Mhz, et sur 7M 7Mhz !

J'ai changé le 74S86 (j'ai mis un 74LS86, mais cela ne devrait pas gêner ?!) = idem.

Je suspect donc déjà un problème sur la partie quartz ?!
Ce que j'ai sur le II+
image.jpeg


Sur l'ITT
image.jpeg


Shéma du quartz
image.jpeg
6502 "Addict" ,mon fils ma bataille...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 884
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Restauration] - ITT 2020

Message non lupar Krapoutchik » 18 nov. 2017, 13:13

Ah oui, il y a clairement un souci :sonar: .

Remplacer un circuit de la série S par un LS n'est pas conseillé, la série S est plus rapide d'environ 30 à 40 % que les LS.

A part ça il est très curieux que le quartz oscille à la moitié de sa fréquence. Normalement un quartz oscille soit sur sa fréquence fondamentale soit sur la 3eme ou 5eme harmonique.
le problème peut provenir du quartz voir du circuit autour mais je pense que tu es déjà parvenu à cette conclusion :8: .
Pour lever le doute, tu pourrais bricoler sur une breadboard un oscillateur à base de 4011, 4069, LS00 ou ls04 de ce genre. Montage ultra simple et rapide à faire ::wink: .
osc.jpg
osc.jpg (30.19 Kio) Vu 18 fois

J'ai déjà fait un montage de ce genre et ai réussi à faire osciller très facilement la majeure partie de mes quartz.
Suivant le quartz (ces petites bêtes peuvent être fourbes :bullwhip: ) il peut être nécessaire de faire un montage un petit plus élaboré de ce genre en rajoutant une porte en sortie (patte 2) pour bufferiser l'oscillation.
osc_para1.gif
osc_para1.gif (2.91 Kio) Vu 18 fois

Si le quartz oscille bien sur sa fréquence, c'est qu'un des totors 2N4258 est un peu mal en point.

Par contre, vérifie bien comment est monté le quartz dans l'ITT car même si son schéma doit comporter pas mal de similitudes avec un 2+ il y a obligatoirement des différences particulièrement pour toute la partie génération de vidéo.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Attafr
Posteur habitué
Posteur habitué
Messages : 26
Enregistré le : 30 oct. 2017, 19:00
Collectionneur (-euse) ? : Oui

Re: [Restauration] - ITT 2020

Message non lupar Attafr » 18 nov. 2017, 23:35

J'ai testé avec ce circuit que j'avais déjà fait !
image.png


J'ai dessoudé le quartz de l'ITT et j'ai testé, même résultat 8.865Mhz j'me suis dis, c'est bon j'ai trouvé le problème :doh:
Ensuite j'ai testé avec un autre quartz de 17.73Mhz que j'avais (la chance) même résultat 8.865Mhz :wall:

J'ai testé ensuite une Quartz de 8 MHz(OK), ensuite test avec un 10Mhz, je me retrouvais denouveau avec cette valeur de 8.865Mhz :eek:

Déduction mon montage me fonctionne pas au delà de 8Mhz :wall: Oui mais j'utilise un 74LS04 et le Dr. a dit LS=Lent ?! Bon pas de HC, mais un 7404 j'ai, échange de Chip et youpi j'ai pu mesurer mon quartz à 17.73Mhz, il est BON ! :clap:

Ce qui me confirme que c'est l'entourage du quartz qui a un soucis je pense, donc je vais continuer à investiguer les 2N4258 et autres... J'ai aussi remarqué qu'il y avait une légère différence dans le circuit quartz du AppleII et de l'ITT, ce dernier a une espèce de petite bobine et un condo au lieu d'une résistance ?!
6502 "Addict" ,mon fils ma bataille...


Retourner vers « 8 bits, Ordinateurs personnels et autres Sasfépus »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité