[Réparation] - Alimentation à découpage et autres bidules

Questions génériques informatiques, vos tutoriaux ou vos astuces de restaurations...

Modérateurs : Membres WDA, Modérateurs complets

Maurice
Messages : 9
Enregistré le : 02 nov. 2017, 09:22
Collectionneur (-euse) ? : Non

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Maurice » 06 nov. 2017, 11:48

Merci de ces conseils.
Une fois dessoudée, la grosse diode conduit dans un sens, mais pas dans l'autre lorsque connectée à l'ohmètre. Idem pour les deux petites diodes zener.
Après une nouvelle inspection minutieuse, je n'ai repéré aucun condensateur déformé ou ayant coulé.
Avant d'attaquer la vérification des résistances du primaire, j'ai mesuré la tension à la patte 2 du CI et là, surprise elle égale 0 alors qu'entre le - et le + marqués en bleu sur le dessous du circuit, je mesure 300 volts.
Je vais donc poursuivre les recherches.

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 905
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Krapoutchik » 06 nov. 2017, 12:05

Si la tension sur la patte 2 est à 0v il faut suivre le chemin, en regardant tes photos j'ai l'impression que l'alimentation du circuit passe par une résistance en série avec une diode, il te faut donc tester ces composants en priorité.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Maurice
Messages : 9
Enregistré le : 02 nov. 2017, 09:22
Collectionneur (-euse) ? : Non

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Maurice » 06 nov. 2017, 14:21

Serait-il possible de dénicher un schéma d'une alimentation à découpage semblable à celle que j'essaie de réparer ? J'ai cherché sur le web, mais je tombe sur des alimentations qui me semblent plus complexes.
Cela me permettrait de mieux comprendre comment ça fonctionne et ce que je dois faire. Bricoler c'est bien, mais apprendre en même temps serait un plus.

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 905
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Krapoutchik » 06 nov. 2017, 14:47

Il suffit souvent de regarder les datasheet des circuits principaux pour avoir des exemples de schéma dont les constructeurs s'inspirent quasiment tout le temps.
Un exemple le datasheet de l'AMS2263
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Maurice
Messages : 9
Enregistré le : 02 nov. 2017, 09:22
Collectionneur (-euse) ? : Non

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Maurice » 06 nov. 2017, 15:35

Merci, le croquis donné par ce datasheet semble ressembler au circuit que j'ai sous les yeux, par contre je n'ai rien trouvé avec la référence LT513 qui renvoie par des Leds...

J'ai dessoudé et testé R5 et D3 (cf photo de mauvaise qualité), sans succès, à l'ohmmètre, tout est bon. Par contre je me demande si j'étais du bon côté du circuit (4 cercles rouges), car la diode D3 aboutit au transfo du secondaire ce qui voudrait dire que l'alimentation du CI se fait de l'autre côté (cf cercle violet dans verso modifié). Je vais essayer de tester toutes les autres résistances.
Capture 2017-11-06 à 15.23.33.jpg
DSC02267 modif1.jpg

Maurice
Messages : 9
Enregistré le : 02 nov. 2017, 09:22
Collectionneur (-euse) ? : Non

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Maurice » 06 nov. 2017, 16:38

Je pense avoir trouvé l'origine de la panne. La résistance R1 de 1MΩ (flèche rouge) ne laisse rien passer à l'ohmètre. Il me faut fouiller dans mon stock mais je ne pense pas avoir de résistances supérieure à 1/4 de watts et elle me semble plus grosse.

On se croise les doigts
DSC02269-2.jpg

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 905
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Krapoutchik » 06 nov. 2017, 17:47

Bravo !!!!

Oui ça pourrait être ça, en suivant le cuivre elle est raccordée au + et alimente le circuit intégré 2263AP et correspond à l'exemple donné dans le datasheet.
En regardant le datasheet, le circuit 2263 consomme 1,5 Ma en moyenne, si la résistance doit faire chuter environ 290V, la puissance dissipée dans la résistance est de : P=UI = 290 X 0,0015 = 0,435 W, il vaut mieux prendre la valeur normalisée au dessus pour plus de sécurité, c'est à dire 1 Watt, provisoirement tu peux mettre 1/2 Watt mais elle risque de ne pas durer très longtemps, quoique à bien regarder je me demande si la résistance HS n'est pas une 1/2 W et elle ne semble pas avoir chauffé :think: .

Attention au condensateur chimique à coté de C5, il est possible qu'il soit HS. tu peux prendre une valeur en µF identique ou légèrement plus élevée et une tension au minimum identique ou largement supérieure.

Toujours en regardant le datasheet, il est dit à la fin que la diode et la résistance en série alimente le circuit une fois l'alim démarrée, la résistance de 1 Mohms n'est là que pour faire démarrer le circuit, une fois que l'alim a démarré c'est la diode et la résistance qui prend le relais puisque les 2 sont connectées à un enroulement du transfo.
Cela pourrait expliquer pourquoi la résistance de 1Mohms semble être une 1/2 W, elle ne sert que pendant quelques centaines de millisecondes le temps que l'alim démarre et se stabilise.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Maurice
Messages : 9
Enregistré le : 02 nov. 2017, 09:22
Collectionneur (-euse) ? : Non

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Maurice » 06 nov. 2017, 18:09

Merci pour le détail des explications, cela m'aide à comprendre ce que je dois faire et pourquoi je le fais.

Sur un vieux poste, j'ai trouvé une résistance de 1MΩ (dans le carré rouge) Le moins aisé à été de la faire rentrer. Je n'ai plus les yeux de mes 20 ans... et j'ai hâte de retrouver l'usage de cette lampe loupe.

Est-ce bien le condensateur marqué d'une flèche rouge qu'il est préférable de changer préventivement ? 10uF 50v, je dois avoir ça sous la main.
DSC02274.jpg

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 905
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Krapoutchik » 06 nov. 2017, 18:48

Top les photos :clap: .

Oui c'est bien ce condensateur là.

Tu as utilisé un chausse pied pour rentrer la résistance :mrgreen: .
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Maurice
Messages : 9
Enregistré le : 02 nov. 2017, 09:22
Collectionneur (-euse) ? : Non

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Maurice » 06 nov. 2017, 19:06

Un très grand merci pour cet accompagnement. Je n'ai pas eu la patience d'attendre ta réponse concernant le condensateur et j'ai de suite essayé si la réparation était la bonne. Le résultat en photo. Je vais pouvoir continuer à bricoler sans m'arracher les yeux... et en plus j'ai découvert votre association, ce forum et appris quelque chose.

Je dois avoir dans un coin de ma cave quelques anciens macs. Je suis Apple depuis mon premier ordinateur en 1984 ou 1985. Cela me donne envie de ressortir le mac SE pour voir s'il fonctionne encore. C'est par contre le temps qui risque de manquer, et là, il n'y a pas de pièce de rechange.

MERCI et à une prochaine. WDA est maintenant dans mes signets
photo.jpg

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 905
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Krapoutchik » 06 nov. 2017, 19:33

Content d'avoir pu t'aider :8: .

Ressusciter un Mac c'est pile, il fonctionne, face, écran rayé...

9 fois sur 10 ce sont les condensateurs sur la carte mèren, on le voit assez vite car ils ont tendance à couler et laissent des traces sur la carte mère.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 905
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Krapoutchik » 12 janv. 2018, 19:34

Aujourd'hui une alimentation compatible pour Apple 2 de marque RACORE COMPUTER modèle 5600-0010 :8: .

Petite particularité, cette alimentation vient d'un vieux PC et a été adaptée ici par Sunplop pour alimenter un Apple 2, elle a exactement les dimensions de celle d'origine, même les vis de fixation sont au même endroit :eeeek: .
component 5600-0010.JPG
Diagnostic d'origine : L'Apple 2 redémarre sans cesse après avoir bippé, signe qu'il s'initialise correctement.

La supervision des tensions et la commande des transistors de puissance du primaire s'effectue à l'aide d'un classique TL494.
Ce qui est plus tordu c'est qu’habituellement l'isolation du primaire et du secondaire s'effectue grâce à un optocoupleur alors que là le TL494 est directement raccordé au secondaire dont il supervise les tensions et est alimenté par un petit transfo classique qui délivre 10V après redressement et filtrage (en haut à droite à coté des 2 gros condensateur).
La commande des transistors de puissance et l'isolation du primaire et secondaire est assuré par l'intermédiaire de 2 petits transfos en ferrite (les 2 jaune et noir les plus à droite).
Le 3eme transfo est utilisé de manière assez curieuse d'après ce que j'en ai déduis :think: . Le primaire est constitué d'une simple spire de fil rouge, ce fil est raccordé d'un coté sur le + 320v à travers un condensateur et de l'autre au point milieu du transformateur de puissance. Le secondaire du transfo est redressé et filtré puis aboutit sur une des pattes de supervision du TL494. Je pense que si cette tension n'est pas dans la fenêtre admissible, le TL494 suralimente ou coupe la commande des transistors de puissance.

Bon ça c'est fait, place à la réparation :mrgreen: .
J'ai raccordé l'alim sur 1 vieux disque dur HS qui consomme environ 25 watts :eeeek: .
1ere constatation, les tensions sont instables et varient de 20 à 30 %, à un moment donné elles se stabilisent aux bonnes valeurs puis ça recommence, on a l'impression qu'il y a un faux contact quelque part.
J'ai vérifié et démonté tous les condensateurs, refait quelques soudures, manipulé plusieurs fois le petit potentiomètre ajustable VR1 (en haut à gauche) et vérifié les nombreuses diodes et quelques résistances placées à des endroits stratégiques.

Fire !!!
RACORE 5600-0010 5V.JPG
Réglage des tensions, connexion d'un 2eme disque pour une consommation totale d'environ 50 watts, les tensions ne bougent quasiment pas avec un disque ou les 2 connectés, un petit coup d'oscillo pour voir si l'alim délivre des tensions bien propre, top, tout est nickel :D !
Pour info, il n'y a qu'un seul réglage de disponible, il vaut mieux bien régler le 5V les autres tensions (+12, -5 et -12) étant moins critiques.
Ici en réglant à 5,18V les autres tensions sont à +12,25, -11,90 et -4,95.

Un petit truc, il vaut toujours mieux régler le +5 légèrement au dessus car à l'autre bout de la carte mère de l'Apple2 qui est assez grande la tension baisse d'environ 200 à 300 millivolts.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Avatar du membre
Sunplop
Posteur motivé
Posteur motivé
Messages : 57
Enregistré le : 12 août 2010, 13:47
Collectionneur (-euse) ? : Oui

Re: [Réparation] - Alimentation à découpage et autres bidules

Message non lu par Sunplop » 12 janv. 2018, 23:44

Cool Olivier !
Voilà donc un //e qui va repartir pour longtemps grâce à tes bons soins, comme d'habitude...
Très content que tu ai fait un petit reportage sur l'opération à cœur ouvert de la bête !
Ah ! Je précise que dans l'exemple que tu donnes en lien, le domino que j'avais mis "à la porchot" :naughty: à bien été remplacé par des soudures isolées avec de la gaine thermo.

P.S. Sympa le vieux disque 5"1/4 pour la charge... :eeeek:

Merci encore Olivier. :clap:
@+
Daniel.
Ma pres.: viewtopic.php?f=21&t=1723
Ma collec.: //c | //e 65c02 + Duodisk + Moniteur // | MAC+ 1/20 | SE/30 12/40 + Eth | LC475 36/250 + Eth | LC III 36/80
Rech: Carte LC Emulation //e | DISK ][ | Souris IIe/IIc

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité