[Qst] - Pb clavier sur Europlus

Discussions sur les PowerPC, anciens 68k et systèmes alternatifs (Distribs Linux, BeOS, OS/2, ...)

Modérateurs : Membres WDA, Modérateurs complets

tilt_93
Membre bénévole WDA
Messages : 149
Enregistré le : 14 mars 2010, 17:34
Collectionneur (-euse) ? : Non

[Qst] - Pb clavier sur Europlus

Message non lu par tilt_93 » 21 mars 2010, 15:35

Bonjour,

Ceux qui ont participé à l'atelier Apple II hier après-midi ont constaté de visu le problème de clavier qui affecte mon Europlus : Très peu de touches fonctionnent normalement. Grosso modo la ligne des chiffres et la première ligne des lettres sont bien actives (sauf les touches 'Reset' et 'Return')
Les touches des autres lignes fonctionnent de façon curieuse : Quand on en presse une, il y a plusieurs caractères qui s'affichent à l'écran.

C'est guère pratique ::(

J'envisage dans un premier temps de demonter l'UC complètement et de contrôler/nettoyer tous les composants.

Mais je pose tout de même la question ici au cas où l'un d'entre vous ait déjà rencontré le problème ou bien ait une piste pour le résoudre...

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 929
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Pb clavier sur Europlus

Message non lu par Krapoutchik » 21 mars 2010, 17:27

Salut,

9 chance sur 10 que ce soit un faux contact dans un support de CI ou dans la petite nappe qui relie le clavier à la carte mère, dans un premier temps appuie bien sur tous les CI sur support qui sont situés juste sous le clavier (machine éteinte bien sûr) et en particulier sur la ROM clavier qui est juste à coté du câble clavier.

Si tu constate un léger mieux, il faut envisager de retirer les circuits intégrés sur supports puis de les remettre, faire l'opération 2 à 3 fois par support pour être sûr d'enlever les éventuelles traces d'oxydation.

Si rien ne change, le problème est sur la carte clavier elle-même, c'est un peu plus ennuyeux à démonter mais sans grande difficulté, faire la même opération sur les circuits sur support.

Tu trouveras à cette adresse le manuel du 2+ http://www.apple-iigs.info/doc/fichiers/appleiiref.pdf.



Tchao et bon courage
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Avatar du membre
Casio
Bureau WDA
Bureau WDA
Messages : 3415
Enregistré le : 23 mars 2004, 10:55
Collectionneur (-euse) ? : Oui
Localisation : Paris XVII / Jouques
Contact :

Re: [Qst] - Pb clavier sur Europlus

Message non lu par Casio » 21 mars 2010, 20:56

Krapoutchik a écrit :Tu trouveras à cette adresse le manuel du 2+ http://www.apple-iigs.info/doc/fichiers/appleiiref.pdf.
Pensez à pérenniser ces informations, comme par ex. par le biais de notre serveur FTP, online depuis 1999.
En effet, si vous vous rendez sur l'arborescence de ce dernier, vous pourrez constater que ce manuel, ainsi qu'un second plus détaillé, sont disponibles au téléchargement. :)

tilt_93
Membre bénévole WDA
Messages : 149
Enregistré le : 14 mars 2010, 17:34
Collectionneur (-euse) ? : Non

Re: [Qst] - Pb clavier sur Europlus

Message non lu par tilt_93 » 25 mars 2010, 22:39

Merci pour vos réponses.

Je vais tenter la manip tranquillement ce week-end.

J'ai vu les scans de docs, particulièrement bien documentés techniquement.
La première concerne le II+ (donc l'Europlus semble t'il), la seconde concerne les modèles plus récent (IIe).
C'est bien utile de les avoir comme cela à dispo. Par contre une remarque, il faudrait l'indiquer plus clairement sur le site, car au départ je pensais qu'il n'y avait que des drivers en download. J'avais pas vu qu'il y avait aussi des docs (ou alors c'est marqué mais j'avais lu trop vite ?)

Avatar du membre
Casio
Bureau WDA
Bureau WDA
Messages : 3415
Enregistré le : 23 mars 2004, 10:55
Collectionneur (-euse) ? : Oui
Localisation : Paris XVII / Jouques
Contact :

Re: [Qst] - Pb clavier sur Europlus

Message non lu par Casio » 30 mars 2010, 16:27

tilt_93 a écrit :(...)Par contre une remarque, il faudrait l'indiquer plus clairement sur le site, car au départ je pensais qu'il n'y avait que des drivers en download. J'avais pas vu qu'il y avait aussi des docs (ou alors c'est marqué mais j'avais lu trop vite ?)
- Hors-sujet -
Merci du feed-back.
En effet, il serait intéressant de rajouter l'info.
Je ne sais pas trop comment opérer. Je vais y penser.
Toute suggestions bienvenues par mail.
- Fin de Hors-sujet -

leduigou
Membre adhérent WDA
Messages : 86
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Pb clavier sur Europlus

Message non lu par leduigou » 01 avr. 2010, 20:46

Bonsoir,
Pour la doc, il y a beaucoup de sites sur le net. J'aime bien celui de Reactive Micro (http://www.reactivemicro.com), il y a de la documentation sur le hardware et des cartes pour donner un coup de jeune à ton Apple II. J'y ai acheté une carte MicroDrive pour mettre tout le système et tous les softs sur une Compact Flash de 128 Mo. C'est super, le Prodos ou le dos 3.3 chargent en 3 secondes et la plus part des soft non protégés fonctionnent. Je ferais un article dans la rubrique test un de ces jours.

As-tu trouvé la cause de la dyslexie de ton clavier ?
Cordialement
Frédéric

tilt_93
Membre bénévole WDA
Messages : 149
Enregistré le : 14 mars 2010, 17:34
Collectionneur (-euse) ? : Non

Re: [Qst] - Pb clavier sur Europlus

Message non lu par tilt_93 » 13 avr. 2010, 21:25

Quelques nouvelles de mon clavier :

Il y a 15 jours, j'ai ouvert le boitier, séparé l'ensemble clavier-encodeur, déposé la carte qui est au dos du clavier, et là je m'attendais à trouver soit de la corrosion, soit des pistes coupées, soit des résidus de nourriture, etc... Bref quelque chose qui donnerai une bonne explication de la panne.

Mais rien de tout cela : la carte est propre, le masque en papier en bon état et la partie mécanique aussi.

Il est difficile de suivre les circuits à la trace, car une partie est sur la carte, et l'autre partie du côté des touches.

J'ai tenté de trouver les raisons du court-circuit entre les pins 2-13-18. Mais j'ai dû arrêter au bout d'un moment car on attendait du monde et il a fallu que je libère la table de la salle à manger...

j'ai donc remonté la carte sur le support plastique et j'ai rangé le tout bien au chaud.
Pas de nettoyage faute de produit adéquat pour le moment.


Le week-end dernier je ressors le clavier, je teste "au cas où" - clavier reposant sur les touches - et là surprise : Fonctionnement correct :P

Je remonte vite fait la carte encodeur et je rebranche le plug sur la carte mère. Power On : ... KO :(

Re-test en démontant le clavier et en posant à l'envers : ca marche !
Je le retroune à l'endroit : ca marche pas !

Bref pour une raison que j'ai du mal à comprendre, mon clavier marche bien seulement quand il a les touches dirigées vers le bas. C'est pas vraiment pratique ::roll:

J'ai pas fini de me prendre la tête sur ce clavier...


PS : Je n'ai pas réussi à insérer des images sur ce post ::oops:

leduigou
Membre adhérent WDA
Messages : 86
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Pb clavier sur Europlus

Message non lu par leduigou » 13 avr. 2010, 22:13

Bonsoir,

Travailler tête en bas, c'est pas top ::lol:
Mon feeling est que ça vient d'un connecteur. Il n'y a que cela qui peut bouger quand tu retournes la carte.

Bon courage.
Cordialement
Frédéric

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 929
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Pb clavier sur Europlus

Message non lu par Krapoutchik » 13 avr. 2010, 22:21

[Edit 14/04/2010 22H05] Je viens de voir que tu avais cross-poster beaucoup plus d'infos sur 2 autres site, tu aurais dû mettre les mêmes infos ici, ça éviterait les pertes de temps et le temps que tu gagnes à ne pas faire un simple copier/coller ne t'honore pas :naughty: . Ceci dit, le clavier de 2+ que j'avais démonté et la touche que j'avais réparée ne ressemblent pas à la photo sur l'autre site, sur le mien les touches étaient soudées sur le cuivre. [ FIN Edit]


Bonsoir,

Où vois-tu un masque en papier, quid du court-circuit en les pattes 2,13,18 (pattes du du CI décodeur de clavier ou du connecteur) , qu'as-tu fais comme manip ?


Quoi qu'il en soit d'après ce que tu dis il semble que ton pb soit plus mécanique que purement électronique, je suppose que tu as vérifié tous les connecteurs et les nappes de connexion...

Soit tu as un trombone coincé entre 2 touches et qui court-circuite les pistes soit tu as une touche dont la partie électrique interne est en vrac, habituellement tu as une petite lamelle qui fait contact quand on enfonce la touche, tu dois avoir cette petite lamelle qui s'est décroché et est tombé sur les contacts au fond de la touche.

Débranche le clavier de la carte décodeur et connecte ton ohmêtre directement sur les broches des touches, le clavier positionné à l'endroit (ça va être sportif la tête en bas !) à un moment donné tu vas avoir une continuité sans manipuler la touche, le problème va être de démonter la touche sans tout péter.


::arrow: Enlever la soudure des broches de la touche avec une pompe à dessouder.
::arrow: La touche est clipsée sur la partie métallique, normalement en appuyant avec un petit tournevis sur les flanc de la touche (donc entre le circuit imprimé et le support métallique) tu devrais pouvoir l'enlever du cadre métallique.
::arrow: Il va falloir décoller le haut de la touche ou couper avec un cutter pour avoir accès à la partie électrique et remettre la lamelle dans sa glissière. Du boulot de précision en perspective. Avec un peu de chance la touche n'est pas collée mais est simplement composée d'éléments clipsés entre eux. Attention il faut démonter la touche par le haut, si tu l'attaques coté broche elle sera définitivement morte :eek:

Atchao
Modifié en dernier par Krapoutchik le 14 avr. 2010, 21:27, modifié 1 fois.
Raison : Petite mise au point...
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

tilt_93
Membre bénévole WDA
Messages : 149
Enregistré le : 14 mars 2010, 17:34
Collectionneur (-euse) ? : Non

Re: [Qst] - Pb clavier sur Europlus

Message non lu par tilt_93 » 16 avr. 2010, 12:47

Bonjour Krapoutchik,

J'ai effectivement posté des messages sur 2 autres forum. Le premier qui est 100% Apple II, plutôt software/hacking, sur les conseils d'un "ancien" de la scène Apple II française. Le second, orienté hardware toute plate-forme, sur les conseils d'un dépanneur info de ma boite.

Je ne voulais pas poluer mais juste avoir plus de chances d'avoir des réponses à mon problème. Ne connaissant pas les us et coutumes des amateurs de micro anciens, et quels ont les sites et forums de prédilections pour ce genre de questions...
Les messages postés devant être identiques, mais dans la pratique ils varient légèrement car je ne poste pas tout le même jour (faute de temps), je tiens compte des réponses et questions qui me sont posés (c'est justement les purs copier/coller que me semblerait être un manque de respect) et ici comme indiqué le 13 avril, je n'ai pas réussi à insérer des images.
J'en suis désolé, car ce post perd un peu de son intéret sans ces images. Il faut que je trouves comme ca marche !

Je te remercie d'essayer de m'aider. J'ai déjà fait les test avec un ohmmètre et repéré que les pins 2-13-18 sont toujours 'up' (continuité) quand le clavier est dans le bon sens.
Alors que clavier à l'envers, il n'y a pas ce problème.
C'est ce "court-circuit" qui entraine les erreurs constatés ordinateur en marche.
Exemple : la touche 'A' ferme comme prévu les pins 9 et 2, mais aussi 9 et 13 qui correspond à la touche J. A l'écran on voit un A suivi d'un J. Logique

Je vais donc chercher à quel endroit les 3 pistes se rejoignent (ce qui n'est pas simple car une moitié du circuit est sur la carte et l'autre moitié sur la matrice support des contacteurs côté touches)

Cordialement

tilt_93
Membre bénévole WDA
Messages : 149
Enregistré le : 14 mars 2010, 17:34
Collectionneur (-euse) ? : Non

Re: [Qst] - Pb clavier sur Europlus

Message non lu par tilt_93 » 16 avr. 2010, 13:06

Bon, je n'arrive toujours pas à insérer mes photos. Message "Impossible de déterminer les dimensions de l’image" :doh:

Voici les liens qui permettent d'y accéder en indirect

- le "bon" schema electrique du clavier des II+ et Europlus (rappel: celui qui est dans le manuel de reference correspond aux anciens clavier des premiers Apple II "tout court")
schemaclaviereuroplus.jpg
Schéma clavier 2+
- la plateforme de test avant le démontage des éléments du clavier :
europlussansboitier.jpg
Euro plus sans boitier
- le clavier déposé (de face) et sa carte contrôleur :
keyboarddepos.jpg
Clavier déposé

- détail de la carte contrôleur (encodeur) avec un condo un peu bouffi, et un autre plus petit formant un pont entre les pins 3 et 6 (montage semble t'il d'origine).
keyboardencoderavecpont.jpg
Encodeur clavier
- le clavier ouvert (on voit la carte support avec les pistes, le cache en papier et le verso des touches qui est en fait une matrice des contacteurs faisant ressorts et formant l'autre moitié des pistes) :eeeek:
claviereuroplusdmont.jpg
Clavier démonté

Si vous savez comment mettre directement les photos ou les thumbails, je suis preneur de l'explication...

Cordialement
Modifié en dernier par Krapoutchik le 17 avr. 2010, 10:09, modifié 3 fois.
Raison : Suppression des liens d'images externes, insertion des images en local.

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 929
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Pb clavier sur Europlus

Message non lu par Krapoutchik » 16 avr. 2010, 22:20

Bonsoir,

J'ai inséré toutes les images téléchargées à partir d'imageshack et ai supprimé les liens externes et n'ai pas eu de soucis.
Pour insérer des photos au format JPG dans un post :
En édition ou création de message, Onglet transférer une pièce jointe, parcourir, ajouter le fichier puis se positionner à l'endroit où l'on veut mettre l'image et faire insérer dans la ligne.

A moins que, comme le dit Leduigou, une nappe de connexion ait un fil qui se balade quand tu retournes le clavier, tu dois nécessairement avoir un bout de métal (trombone, agraphe ?)qui se promène sur les pins 2 et 13 sur le clavier ou alors sous le circuit intégré décodeur clavier (AY 5-3600) entre les pattes 36 et 38.

Je n'ai guère d'autres idées pour le moment.

Atchao
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

pcedric
Posteur assidu
Posteur assidu
Messages : 83
Enregistré le : 19 mars 2010, 09:45
Collectionneur (-euse) ? : Non

Re: [Qst] - Pb clavier sur Europlus

Message non lu par pcedric » 27 avr. 2010, 12:51

Salut tilt, on s'est rencontré lors de la journée Apple 2.

Je suis heureux de voir que tes recherches avances.

Petite suggestion à deux balles: d'après mes souvenirs, lorsque tu appuis sur une touche 'défectueuse', celle ci s'affiche et la touche suivante s'affiche aussi (quelque fois l'ordre est inversé). Met un petit bout de scotch sous la touche J par exemple, et test la touche H. Si le caractere J continue d'apparaitre en plus du H, il ne s'agit pas d'un court circuit sous les touches.

Impression: une petit demontage du circuit encodeur avec un nettoyage au K2 ne couterait rien (sauf peut etre a casser une patte...)

tilt_93
Membre bénévole WDA
Messages : 149
Enregistré le : 14 mars 2010, 17:34
Collectionneur (-euse) ? : Non

Re: [Qst] - Pb clavier sur Europlus

Message non lu par tilt_93 » 04 mai 2010, 16:33

Bonjour Pcedric,

J'ai déjà séparé le circuit encodeur du reste du clavier, et j'ai vérifié les infos que le circuits reçoit : Elle sont erronées.
L'encodeur transcrit à l'écran les (mauvaises) infos qu'il reçoit.

je suis rentré de congés ce week-end, aussi je vais pouvoir recommencer les tests très bientôt.

Merci pour ton support

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 929
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Pb clavier sur Europlus

Message non lu par Krapoutchik » 04 mai 2010, 18:10

Il y avait Dallas et son univers impitoyaaaaable, désormais on pourra dire AAAAAApple... ton clavier miséraaaaaaa-ableu :wall: :wall: ::lol:
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité