[Pb] - Carte Porte-Parole pour Apple IIe

Discussions sur les PowerPC, anciens 68k et systèmes alternatifs (Distribs Linux, BeOS, OS/2, ...)

Modérateurs : Membres WDA, Modérateurs complets

quarks13
Messages : 7
Enregistré le : 10 mars 2013, 00:19
Collectionneur (-euse) ? : Oui

[Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar quarks13 » 23 déc. 2013, 11:31

J'ai posté également sur un autre forum (system-cfg) mais je préfère doubler, au cas où…

Voilà des années que je cherchais désespérément la carte "Porte-Parole" d'Ediciel, que nous avions dans l'Apple IIe familial vers 1984. J'ai fini par la trouver dans un lot Apple IIe. J'ai donc acheté l'ordi complet, qui fonctionne parfaitement. Cependant, je n'arrive à sortir aucun son de la carte. De toute évidence, ça n'est pas la carte d'origine fabriquée par Ediciel mais une réplique au look "homebrew" avec pour seul point commun avec l'originale le fameux chip MEA8000.
Le vendeur m'affirme pourtant l'avoir testée avant de m'envoyer l'ordi (et j'ai toutes les raisons de le croire sur parole).

Elle est dans son slot d'origine (4) et le logiciel semble bien configuré pour ce slot. Au lieu du connecteur cinch et du connecteur pour le hp du IIe, cette carte possède deux connecteurs cinch. Un connecteur "HP" et un autre "AMP". J'ai testé les deux sur les entrées de ma carte son, tout ce que j'obtiens est un fort bruit de fond désagréable ainsi que les accès disque…

Au passage, si quelqu'un avait la carte d'origine Ediciel Porte-Parole et voulait s'en débarrasser, je cracherais pas dessus ;-)

IMG_9855s.jpg
Carte "Porte-Parole" pour Apple II.


Edit :

Il y a une évolution !

En fait, lorsque je charge les messages parlés sauvegardés sur la disquette, je peux les écouter…
Idem pour le programme "Clavier Parle", qui me lit l'alphabet et les chiffres sans problème…
Donc la carte est bien fonctionnelle, ainsi que ses deux sorties cinch.

En revanche, dès que j'essaye d'éditer moi-même une phrase (que ce soit en français ou en phonétique), rien ne sort…

Dans le doute, j'ai re-créé une nouvelle disquette programme "porte-parole" à partir d'ADT Pro, mais ça n'a rien solutionné.
Modifié en dernier par Casio le 23 déc. 2013, 19:03, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre, titrage de la photo & rassemblement des 2 posts consécutifs.

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 798
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar Krapoutchik » 23 déc. 2013, 20:51

Visiblement un pb soft, disquette protégée en écriture, programme protégé ?
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

quarks13
Messages : 7
Enregistré le : 10 mars 2013, 00:19
Collectionneur (-euse) ? : Oui

Re: [Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar quarks13 » 25 déc. 2013, 09:48

J'ai envisagé un pb soft, effectivement, mais toutes les copies du soft, même la version originale, me donnent le même problème.
Entre temps j'ai quand même réussi à obtenir du son, après avoir chargé un son sauvegardé sur la disquette. Mais le simple "BONJOUR" que j'ai entré au clavier s'est transformé en un charabia extraterrestre incompréhensible et sans aucun rapport de durée avec ce que j'avais entré. J'ai donc tenté de ré-enficher la carte, redémarrer l'ordi, mais je ne suis pas arrivé à reproduire le phénomène. Donc j'aurais tendance à pencher vers un problème hardware…

J'aimerais d'ailleurs trouver la disquette "utilitaires" EDI-LOGO sur laquelle se trouve un petit programme qui fait parler la carte Porte-Parole. Je n'ai malheureusement trouvé que la disquette programme (Asimov)

C'est ce qu'on entend à 3'18" sur cette vidéo : http://www.youtube.com/watch?v=20gtabDBVFY

[EDIT] J'ai trouvé la disquette 2 "Utilitaires" sur un autre site mais le programme en question "PICOLO.PARLE" ne se trouve pas dessus… Pas de bol, moi ;-)

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 798
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar Krapoutchik » 25 déc. 2013, 22:46

Ta carte fonctionne puisqu'elle lit les messages exemples, le soft de lecture aussi...

Logiquement le problème semble venir de la création de la séquence correcte par le soft. Il est très possible qu'une protection existe pour cette partie du logiciel où que celle ci nécessite une configuration précise, par exemple, un certain nombre de soft APPLE ne fonctionnent que sur des machines à base de 6502 mais ne fonctionnent plus sur des machines plus récentes à base de 65C02.

Pourquoi ?

Car le 6502 comporte des instructions non documentées qui ont souvent été utilisées pour effectuer des opérations non standards ou pour cacher le fonctionnement du soft et rendre plus compliqué son désassemblage.

Le 65C02 a supprimé la quasi totalité de ces instructions fantômes ou les a transformé.

Tout ça pour dire que ta machine est peut-être à base de 65C02 et ton soft comporte des morceaux de code qui utilisent des instructions non documentées 6502.

L'inverse peut-être vrai, un soft conçu pour un 65C02 ne tournera pas sur un 6502 mais généralement ces logiciels détectent le type de processeurs et préviennent de l'incompatibilité.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

quarks13
Messages : 7
Enregistré le : 10 mars 2013, 00:19
Collectionneur (-euse) ? : Oui

Re: [Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar quarks13 » 25 déc. 2013, 23:20

Je n'avais pas pensé à cette éventualité (par pure ignorance…) mais il se trouve que cette machine, cette carte et ce soft étaient solidaires et fonctionnels jusque-là.
J'ai même retrouvé sur la disquette des messages enregistrés par l'ancien propriétaire. S'il a pu les enregistrer c'est vraisemblablement qu'il les a programmés, donc écoutés… En outre, il me dit avoir testé la-dite carte "Porte-Parole" avant que je récupère la machine.

De mon côté je me suis demandé si une des cartes que j'ai récemment ajoutées ne créait pas un conflit quelconque…
La config de départ est : Carte Parallèle, Carte CP/M, Carte Chat Mauve, Carte Porte-Parole, Contrôleur DIsk II
J'ai remplacé la carte parallèle Apple d'origine par une Super-Serial (Apple) et ajouté, en sus de la carte Disk II, une carte contrôleur DuoDisk.
Je ne peux pour l'instant pas me passer de la carte DuoDisk, vu que mon seul et unique Disk II est défaillant et que ceux qui étaient avec l'ordi sont à 1000 bornes d'ici (je vous la fais en bref : j'ai acheté cet ordi en Bretagne, ma mère - sur place - est allée le chercher et j'ai n'ai récupéré cet été que les élements qui pouvaient rentrer dans la voiture…). Peut-être que carte DIsk II et DuoDisk c'est trop ?
Quoiqu'il en soit, hormis la carte CP/M et DuoDisk, on est dans la même config que celle de mon père en 1984, et qui fonctionnait nickel avec la "Porte-Parole"…

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 798
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar Krapoutchik » 25 déc. 2013, 23:56

La solution est certainement dans le changement de config et des softs réagissent mal à la présence de plusieurs cartes contrôleurs disques, la solution est peut-être là ?
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

quarks13
Messages : 7
Enregistré le : 10 mars 2013, 00:19
Collectionneur (-euse) ? : Oui

Re: [Pb] - Carte Porte-Parole pour Apple IIe

Message non lupar quarks13 » 26 déc. 2013, 01:24

Ok. Je tâcherai de faire un test avec la config minimum en enlevant les cartes qui ne me servent pas… ::wink:


Retourner vers « APPLE & Systèmes alternatifs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité