[Test] - Tentative de réparation IBM T41

Problème technique ou logiciel, plantages, ennuis viraux ou simplement nous faire part de votre expérience...

Modérateurs : Membres WDA, Modérateurs complets

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 805
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

[Test] - Tentative de réparation IBM T41

Message non lupar Krapoutchik » 04 janv. 2011, 23:52

Hello !

Premier bidouillage de l'année !

Je vous l'avais promis il a quelques semaines (hum... mois ::oops: ) je me suis enfin lancé dans une réparation acrobatique et périlleuse :bullwhip:

Alors qu'avons nous aujourd'hui dans notre escarcelle ?

A ma gauche, un magnifique portable IBM T41 qui a un peu vécu mais qui a encore de beaux restes, à ma droite... euh... à ma droite rien du tout ::lol:

Bon... magnifique OK mais de beaux restes, finalement, je n'en suis pas si sûr !

Eh oui après plusieurs séquences de démarrages et d'extinctions il faut se rendre à l'évidence il y a comme qui dirait un bug :doh:
Après 2 ou 3 minutes de chauffe la machine ne réagit plus, de temps en temps l'écran se modifie, changement/inversion de couleur, caractères parasites mal formés... en bref de gros problèmes vidéos en plus du plantage obligatoire.

Comme d'habitude direction gougueule pour voir si je suis le seul au monde à avoir ce type de problème, 2 minutes plus tard le résultat est sans appel, le T41 a une maladie génétique :eek: euh... non... je m'égare... je voulais dire un défaut de conception ::twisted:.

Pour faire court, le boitier à une certaine flexibilité et la carte mère vrille à l'endroit précis où est soudé une petite carte supportant la mémoire et le chipset vidéo ATI. A mesure que le temps passe une faiblesse apparait au niveau des soudures de la carte et...plantage.
Le problème est que cette carte ne peut être dessoudée/ressoudée sans moyen technique important, en fait, même pour le constructeur ça revient plus cher de réparer que de fabriquer une carte, en mot IRREPARABLE :nuclear: .
C'est sans compter l'ingéniosité d'allumés pour qui rien n'est impossible, le but est de ressouder la carte avec des moyens dignes de Mac-Gyver.
C'est simple il suffit d'un pistolet à air chaud genre décapeur thermique.
Mouais... je suis un peu sceptique, de nombreux témoignages et vidéos montrent la réussite de l'opération :liar: , seul une personne déclare que 1 carte sur 5 testées a pu être réparée, j'aurais plutôt tendance à croire cette version.
Le but du jeu est donc de chauffer suffisamment la carte pour faire refondre les soudures mais pas trop car les points de contacts sont tellement rapprochés que si la goutte de soudure coule elle occasionne un court circuit avec sa copine qui est située un dixième de millimètre plus loin !
Un article très instructif en grand breton est trouvable sur GOOGLE en tapant Reflow soldering processes and troubleshooting: SMT, BGA, CSP, and flip chip comme mots clefs ou Ball grid array vous aurez alors idée de la difficulté à surmonter :wall: :wall:

Grosso modo il ne faut pas dépasser 210° et ne pas rester à cette température plus de 30 secondes. Sans régulations électronique du flux d'air chaud ni thermocouple cela me semble voué à l'échec !
Qui ne risque rien n'a rien :pray: , d'autant plus qu'il n'y a pas de différence entre un portable qui fonctionne 2 minutes et un portable HS

Après quelques recherche, je trouve que le papier s'enflamme à partir de 235 °, ça me fera un excellent témoin de la température à ne pas dépasser, dès qu'il commencera à roussir, je diminuerai le flux d'air chaud en m'éloignant un peu puis me rapprocherai, ce manège durera une trentaine de secondes.

Bon démontage, il me faut bien une bonne demi heure pour arriver à démonter la carte mère en prenant soin de prendre des photos et de noter l'emplacement de toutes les vis et il y en a un paquet ! des longues, des courtes, des moyennes, à petites ou grosses têtes....
demontageT41.JPG


On y voit déjà un peu plus clair, le dénouement est proche, on voit bien l'objet du délit ,au centre (chipset ATI) !
demontageT41-2.JPG


Évidemment il faut protéger l'ensemble de la carte et des connecteurs en plastique.
aluT41-1.JPG


Ca y est, y a plus qu'à !
aluT41-2.JPG



Au bout de 10 minutes dont les 3 quarts en préchauffage tout doouououououcement pour amener la carte à température, j'ai un petit peu merdu car mon témoin en papier s'envolait ! j'ai du m'en sortir rapidement en coinçant le témoin dans un bout de papier d'aluminium coincé lui même dans le sandwich d'alu enroulé autour de la carte. J'oubliais... il ne faut absolument pas bouger la carte pendant le chauffage ni pendant le refroidissement.

Après une bonne demi heure de repos, la carte a retrouvé une température normale, je la déshabille de son sandwich d'alu, ah...déjà c'est bon signe rien n'a brulé sur la carte et les connecteurs en plastique ainsi que le support du processeur sont intacts.

Remontage avec les vis !

Test....


Et....


Bouhhhoouhouh, la machine ne s'allume pas, il se passe quelque chose au niveau des voyants d'allumage mais ça ne dure qu'un dixième de secondes.

Je n'y croyais pas trop mais je suis un peu déçu quand même, bon on ne gagne pas à tous les coups !

A bientôt pour un prochain bidouillage !!


Krapoutchik
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

leduigou
Membre adhérent WDA
Messages : 84
Enregistré le : 06 janv. 2010, 08:34
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Test] - Tentative de réparation IBM T41

Message non lupar leduigou » 09 janv. 2011, 13:51

Cette tentative est très instructive, et comme tu dis, ... pas à tous les coups !

Better luck next time ... :pray:
Cordialement
Frédéric

pcedric
Posteur assidu
Posteur assidu
Messages : 83
Enregistré le : 19 mars 2010, 09:45
Collectionneur (-euse) ? : Non

Re: [Test] - Tentative de réparation IBM T41

Message non lupar pcedric » 04 mars 2011, 00:37

Vraiment très audacieux !!! :eek:
Comme on dit, qui ne tente rien n'à rien...
En tout cas :respect:

Olivier
Messages : 3
Enregistré le : 16 janv. 2011, 09:50
Collectionneur (-euse) ? : Non

Re: [Test] - Tentative de réparation IBM T41

Message non lupar Olivier » 19 mars 2012, 17:36

salut krapoutchic, je me suis penché sur un dell xps m1530 et un vaio fz21e.J'ai "reflowé" les gpus qui avaient une maladie de soudure(8400m gt).Mauvaise conception? Mauvaise qualité d'étain? Je n'en suis pas sûr.Ce qui est sûr c'est que je les ais passés au canon à chaleur ~à 480° pendant deux minutes.La première fois, je n'ai rien modifié au niveau hardware/logiciel et le problème est revenu.la deuxième fois j'ai essayé d'underclocker logiciellement(je ne suis pas certain de l'efficacité des logiciels) et donc c'est revenu.Depuis j'ai forcé la marche en 12v constant des ventilos et ça semble tenir.Tout ça pour dire que tu penses être arrivé au point de "liquéfaction" de la soudure?
edit: des gens sur internet les passent au four :/

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 805
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Test] - Tentative de réparation IBM T41

Message non lupar Krapoutchik » 19 mars 2012, 22:16

Bravo pour tes essais :clap:

J'apprécie à sa juste valeur tes efforts car c'est du boulot :boohoo:

Dans ton cas je pense que tu peux avoir aussi un problème de chipset défectueux et le reflow ne peut pas grand chose pour ce genre de problème. J'ai un DELL et un Toshiba dont le chipset graphique est HS, le Tosh ne démarre pas et le DELL ratatouille au bout de 5 secondes et un chauffage léger n'y a rien changé

Depuis cet essai de réparation, j'ai un peu gagné en expérience dans le maniement du pistolet à air chaud et m'en sers souvent pour faire de la récup réussie de composants sur de la carte mère de pc standard et je pense avoir trop chauffé la carte du T41. Mon pistolet (un décapeur de peinture) a 2 positions, 300 et 450°, pour du reflow je crois qu'il vaut mieux rester sur 300 en étant un peu éloigné de la carte pour ne dépasser les 210° et ne pas risquer la surchauffe du chipset.
Je pense d'ailleurs attaquer dans les prochaines semaines un autre T41 qui a un problème absolument identique :nuclear: .

Par contre, ce qui est sûr c'est qu'à un moment donné il est obligatoire de nettoyer la vieille pâte thermique et d'en mettre de la nouvelle (à dose homéopathique), j'ai récemment "réparer" un ASUS qui chauffait comme un furieux, ventilo toujours à fond, et plantait au bout de 30 à 45 mn, j'ai enlevé la vieille pâte sur le proco et le chipset graphique avec beaucoup de difficulté car elle était d'une dureté incroyable, depuis la bécane ne plante plus,ne chauffe plus ou quasiment et le ventilo a retrouvé sa sérénité (bien sûr il faut aussi bien nettoyer tout le système de refroidissement).

A bientôt pour de nouvelles expériences
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Zed80
Posteur habitué
Posteur habitué
Messages : 23
Enregistré le : 15 mars 2012, 21:30
Collectionneur (-euse) ? : Non

Re: [Test] - Tentative de réparation IBM T41

Message non lupar Zed80 » 20 mars 2012, 00:08

Tiens donc, on s'essaye au décapeur thermique ? ::wink:

Personnellement je suis un peu chanceux car j'ai un vrai fer à air chaud avec température réglable. Par ailleurs je suis moi même empêtré dans la réparation d'un portable avec un GPU à rebiller.

Alors sur les température maxi, vous pouvez y'aller franco, enfin, toutes proportions gardées, c'est fait pour résister à des grosses chaleurs ces cartes là (du moins si c'est pas du matos antédiluvien). Et si les réparations au four foirent ou ne tiennent pas longtemps c'est parce que il n'y a pas eu assez de chaleur pour refondre les soudures.

Avec un décapeur thermique il y a une part de risque, mais le truc c'est d'acheter un multimétre sur ebay avec sonde thermique, on en trouve à 35 euros, voire moins.

Il faut pouvoir atteindre 280 C°, au delà c'est inutile. En dessous réparation peu durable ?

Attention a monter en température tout doucement car si on applique directement le flux d'air chaud ca peut faire cloquer le plastique du GPU. Donc faut y'aller sur plusieurs minutes. A 280°C les soudures seront complètement liquides donc le moindre mouvement et le GPU se barre et c'est la catastrophe.

Dernière chose sur un vieux PC, il faut aussi checker les gros condensateurs de l'alim, ou des fois sur la mobale, mais je ne vous apprendrai pas votre métier.. ;-)


Retourner vers « Questions, Conflits, Problèmes, Virus ou Astuces ? »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité