[Qst] - Ce KVM me rend fou !

Problème technique ou logiciel, plantages, ennuis viraux ou simplement nous faire part de votre expérience...

Modérateurs : Membres WDA, Modérateurs complets

Gwel88
Posteur habitué
Posteur habitué
Messages : 28
Enregistré le : 20 mai 2012, 11:54
Collectionneur (-euse) ? : Oui
Localisation : Vosges

[Qst] - Ce KVM me rend fou !

Message non lupar Gwel88 » 08 févr. 2014, 19:34

Bonsoir à tous,

je me tourne vers vous car je ne sais plus quoi faire. Un ami m'a confié un KVM 2 x DIN/DB9/VGA, avec un bouton rotatif, qui présentait un problème de non fonctionnement de la souris (DB9 donc). En testant les pins 1à 1, j'ai trouvé que la data était coupée, et que cela semblait provenir du sélecteur. Je démonte donc celui-ci (aaaah :wall: ) et après 2H de remontage, je réussi à avoir toutes les lignes OK au testeur diode, et pas de CC. Seulement voilà, toujours pas de souris, quelque-soit l'entrée, la souris, ou la machine utilisée. Je ne sais pas du tout où regarder, j'ai pensé à une capacité induite créee par le couple curseur/piste du sélecteur, mais ça me paraît improbable.

Avez-vous déjà eu ce genre d'expérience ou une idée de quel pourait être le problème ? J'ai pris tout un tas de photos du démontage remontage du sélecteur, avec la bonne méthode c'est assez simple, je posterai tous ça si j'arrive à faire fonctionner le bouzin.
Modifié en dernier par Casio le 08 févr. 2014, 21:40, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre + Déplacement du sujet dans un topic plus approprié.

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 883
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Ce KVM me rend fou !

Message non lupar Krapoutchik » 21 févr. 2014, 14:01

Si c'est un KVM sans électronique, avec un switch qui commute toutes les lignes, il n'y a pas 36 solutions cela ne peut-être qu'un souci de fil coupé, faux contact ou court circuit avec une autre ligne.
Ce dernier point est le plus vraisemblable si tu as toutes les continuités. Sur ce type de matériel tous les fils sont soudés à la main et tu peux vite avoir une soudure un peu trop généreuse ou un brin de fil qui taquine son voisin ::( .
La seule solution est de s'armer de patience et de tester chaque fil un par un avec son plus proche voisin, un conseil... positionne ton multimètre en beepeur, la fonction est faite pour ça et évite de devoir regarder l'affichage à chaque fois que tu testes un fil.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Gwel88
Posteur habitué
Posteur habitué
Messages : 28
Enregistré le : 20 mai 2012, 11:54
Collectionneur (-euse) ? : Oui
Localisation : Vosges

Re: [Qst] - Ce KVM me rend fou !

Message non lupar Gwel88 » 24 mars 2014, 15:37

J'ai trouvé !

C'était pourtant si simple ... quand j'ai testé la continuité des lignes (avec le beeper, c'est indispensable), je pointais les pins coté intérieur, sur les soudures et donc pas de soucis, sauf qu'un des pins était cassé dans la prise master du KVM, et qu'il tenait toujours bien, sans conduire évidemment !

Si j'avais su, je ne l'aurais pas laissé de coté pendant 1 mois, le pire c'est que le pin cassé est celui de la DATA, donc la même ligne coupée dans le sélecteur. Au passage, voilà à quoi ressemble le sélecteur une fois démonté, le plus compliqué étant de trouver la technique de remontage, ensuite ça va tout seul.

IMG_20131219_184421.jpg
IMG_20131219_184416.jpg


Projet suivant: un switch SCART d'au moins 10 entrées RGB et de bonne qualité. Merci à toi pour tes conseils.

Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 883
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Ce KVM me rend fou !

Message non lupar Krapoutchik » 24 mars 2014, 16:36

Bravo :clap: :clap:

Trop fort le démontage du sélecteur, je ne sais pas si j'aurai eu ta patience :eek: .
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

Gwel88
Posteur habitué
Posteur habitué
Messages : 28
Enregistré le : 20 mai 2012, 11:54
Collectionneur (-euse) ? : Oui
Localisation : Vosges

Re: [Qst] - Ce KVM me rend fou !

Message non lupar Gwel88 » 24 mars 2014, 21:49

Si ça peut servir, ça m'a pris 3 ou 4 essais avant de trouver la bonne méthode. Le problème était qu'une des lamelles-ressort était applatie avec le temps, et donc était partie de son logement, donc première étape, toutes les redresser une par une, suite à quoi nettoyage des pistes au Kontact 60 et on attaque le gros boulot.

J'ai fini par mettre l'axe, bouton vers le bas, dans une grosse pince plate fermée avec un élastique, puis la première rondelle en plastique ainsi que les deux vis, calées pour qu'elle ne puissent pas redescendre. Premier circuit en le tenant au fond avec la main gauche et en posant tous les contacts avec la droite, deuxième rondelle, puis deuxième circuit, etc. toujours en tenant fermemant le tout vers le bas, les lamelles ont la facheuse tendance à partir à droite à gauche. Finalement, la plaque du fond et je serre les deux vis-écrou assez fort.

Ca devient assez vite le Bronx, avec tous les fils qui empêchent de manipuler des plaques à pistes correctement, mais ça vallait le coup, puisque tout fonctionne.

Avatar du membre
Scoot
Messages : 8
Enregistré le : 02 juil. 2015, 09:30
Collectionneur (-euse) ? : Oui
Localisation : Vosges

Re: [Qst] - Ce KVM me rend fou !

Message non lupar Scoot » 02 juil. 2015, 14:21

je ne te remercierai jamais assez pour ta patience et ton talent l'ami !
(c'est moi qui lui ai refilé ce malade à soigner)
Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison


Retourner vers « Questions, Conflits, Problèmes, Virus ou Astuces ? »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités